Raspberry PyQt 安装

在raspberry使用网易云音乐涉及到pyqt的使用,由于版本不对应等问题导致安装失败,特此记录下pyqt对应的版本安装。

首先更新软件源

sudo apt-get update
sudo apt-get upgrade

安装libqt4-devShell软件包

sudo apt-get install libqt4-dev

进行SIPShell的安装

cd ~wget http://sourceforge.net/projects/pyqt/files/sip/sip-4.17/sip-4.17.tar.gztar vxf sip-4.17.tar.gzcd sip-4.17python configure.pymakesudo make install

最后安装pyq

cd ~wget http://sourceforge.net/projects/pyqt/files/PyQt4/PyQt-4.11.4/PyQt-x11-gpl-4.11.4.tar.gztar vxf PyQt-x11-gpl-4.11.4.tar.gzcd PyQt-x11-gpl-4.11.4python configure.pymakesudo make install

pyqt安装等了30分钟左右

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Title - Artist
0:00