Django2.0 + Python3 + PyMySQL0.7.11 配合使用时报以下异常

Django2.0 + Python3 + PyMySQL0.7.11 配合使用时报以下异常

django.core.exceptions.ImproperlyConfigured: mysqlclient 1.3.3 or newer is required; you have 0.7.11.None

由于PyMySQL对应的MySQL驱动无法满足>1.3.3;所以我们又两种方式解决。

方案一:(推荐)

直接升级PyMySQL模块

pip install -U PyMySQL

方案二:

这时我们只需要把保错的文件修改下

vim /Users/lubaogui/PycharmProjects/OysterStore/ss_env/lib/python3.5/site-packages/django/db/backends/mysql/base.py

注释掉35~36行

#if version < (1, 3, 3): ## raise ImproperlyConfigured("mysqlclient 1.3.3 or newer is required; you have %s" % Database.__version__) [/shell]

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Title - Artist
0:00